Email Processing delays

Incident Report for Popmenu

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 15:37 EST

Update

We are continuing to work on a fix for this issue.
Posted Mar 04, 2025 - 13:51 EST

Identified

We have identified an issue impacting email processing, causing delays in handling email details. Our team is actively investigating the root cause and working on a resolution. We will provide updates as we make progress toward full recovery.
Posted Mar 04, 2025 - 13:51 EST
This incident affected: My Popmenu (My Popmenu Admin Platform).