AI Answer Dashboard is not displaying current information
Incident Report for Popmenu
Resolved
This incident has been resolved.
Posted Nov 11, 2023 - 08:19 EST
Identified
We have identified an issue with AI Answer Dashboard not displaying current information
Posted Nov 10, 2023 - 14:26 EST
This incident affected: AI Answering (Voice - Twilio).