Facebook and Instagram Connection Issues

Incident Report for Popmenu

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 13:50 EDT

Investigating

Meta is currently experiencing a major service disruption affecting both Facebook and Instagram. As a result, we may see related issues affecting our integrations and functionality tied to these platforms. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted Jun 12, 2026 - 11:04 EDT
This incident affected: My Popmenu (Facebook and Instagram Integration).