Some customers are experiencing issues with Online Ordering.
Incident Report for Popmenu
Resolved
This incident has been resolved.
Posted Jan 16, 2024 - 18:06 EST
Identified
Our team is investigating an issue impacting some clients. We are working as quickly as possible to resolve it. We greatly apologize for the inconvenience!
Posted Jan 16, 2024 - 14:07 EST
This incident affected: My Popmenu (My Popmenu Admin Platform) and Online Ordering and Delivery (Customer Online Ordering).