Some websites are currently not displaying properly

Incident Report for Popmenu

Resolved

This incident has been resolved.
Posted Jul 17, 2024 - 15:56 EDT

Update

Our team is working diligently to resolve the issue as quickly as possible.
Posted Jul 17, 2024 - 14:18 EDT

Investigating

Our team is investigating an issue impacting some clients. We are working as quickly as possible to resolve it. We greatly apologize for the inconvenience!
Posted Jul 17, 2024 - 14:18 EDT
This incident affected: My Popmenu (My Popmenu Admin Platform) and Customer Websites (DNS Routing).