Issues logging into the popmenu admin platform

Incident Report for Popmenu

Resolved

This incident has been resolved.
Posted Dec 28, 2024 - 16:59 EST

Investigating

We are currently investigating reports logging into popmenu admin platform
Posted Dec 28, 2024 - 16:44 EST
This incident affected: My Popmenu (My Popmenu Admin Platform).