Answering Service Interruption
Incident Report for Popmenu
Resolved
This incident has been resolved.
Posted Nov 13, 2023 - 14:42 EST
Investigating
The Answering service is currently experiencing issues handling inbound phone calls.
Posted Nov 13, 2023 - 14:40 EST
This incident affected: AI Answering (Voice - Twilio).