We've implemented measures throughout the day to improve stability for My Pop and customer websites. Our team continues to work closely with our cloud provider to fully resolve the issue.
Posted Oct 20, 2025 - 15:13 EDT
Investigating
Users may experience latency and degraded performance when accessing My Pop and customer websites due to issues with our public cloud provider. We're working with our provider to mitigate the issue.
Posted Oct 20, 2025 - 10:48 EDT
This incident affected: My Popmenu (My Popmenu Admin Platform, Web Builder, Popmenu for Owners App, Facebook and Instagram Integration), Customer Marketing and Communication (Email Delivery - SendGrid, SMS Delivery - Twilio, Meta API, Twitter API, OpenAI), AI Answering (Voice - Twilio), Online Ordering and Delivery (OrderNerd Platform, DoorDash Drive API, Customer Online Ordering), Customer Websites (DNS Routing, MyPop CMS), and Payment Processing (Stripe API, Spreedly Core Transactional API, Square API, Toast POS Integration, Everyware API, Clover API).