Email Processing delays

Incident Report for Popmenu

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 15:30 EDT

Monitoring

We have identified and addressed an issue causing email processing delays. A resolution has been applied, and we are actively monitoring to ensure full recovery.
Posted Mar 18, 2025 - 13:30 EDT
This incident affected: My Popmenu (My Popmenu Admin Platform).