Clover Outage Impacting Order Processing

Incident Report for Popmenu

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 19:21 EDT

Identified

We are currently aware of an issue affecting some customers’ ability to process orders via Clover. This is due to an ongoing outage on Clover’s end. For more details and real-time updates, please visit Clover’s status page: https://status.clover.com/incidents/5sxn7mhdt1k6.
Posted Aug 15, 2025 - 16:17 EDT
This incident affected: Payment Processing (Clover API).